summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mtr/mtr-0.69.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.69.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/mtr/mtr-0.69.ebuild b/net-analyzer/mtr/mtr-0.69.ebuild
new file mode 100644
index 000000000000..840cd51eef5c
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.69.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.69.ebuild,v 1.1 2005/02/02 11:18:13 ka0ttic Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
+IUSE="gtk gtk2 ipv6"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=">=sys-libs/ncurses-5.2
+ gtk? (
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-ac-res_mkquery.patch
+}
+
+src_compile() {
+ autoconf || die "autoconf failed"
+
+ local myconf
+ use gtk || myconf="${myconf} --without-gtk"
+
+ append-ldflags -Wl,-z,now
+
+ econf ${myconf} \
+ $(use_enable gtk2) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # this binary is universal. ie: it does both console and gtk.
+ make DESTDIR=${D} sbindir=/usr/bin install || die "make install failed"
+
+ insinto /usr/share/${PN} ; doins img/mtr_icon.xpm
+
+ fowners root:wheel /usr/bin/mtr
+ fperms 4710 /usr/bin/mtr
+
+ dodoc AUTHORS COPYING ChangeLog FORMATS NEWS README SECURITY TODO
+}