summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nettop')
-rw-r--r--net-analyzer/nettop/ChangeLog6
-rw-r--r--net-analyzer/nettop/files/digest-nettop-0.2.32
-rw-r--r--net-analyzer/nettop/files/nettop.c.patch45
-rw-r--r--net-analyzer/nettop/nettop-0.2.3.ebuild10
4 files changed, 56 insertions, 7 deletions
diff --git a/net-analyzer/nettop/ChangeLog b/net-analyzer/nettop/ChangeLog
index 6d95441b1b37..cd01761dfd1c 100644
--- a/net-analyzer/nettop/ChangeLog
+++ b/net-analyzer/nettop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nettop
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.13 2006/02/15 23:30:09 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.14 2006/07/08 13:28:30 dragonheart Exp $
+
+ 08 Jul 2006; Daniel Black <dragonheart@gentoo.org> files/nettop.c.patch,
+ nettop-0.2.3.ebuild:
+ gcc-4.1.1 fix thanks to Pylon
15 Feb 2006; Markus Ullmann <jokey@gentoo.org> nettop-0.2.3.ebuild:
Removing virtual/libpcap wrt bug #117898
diff --git a/net-analyzer/nettop/files/digest-nettop-0.2.3 b/net-analyzer/nettop/files/digest-nettop-0.2.3
index 360980f9f256..626cebcb1308 100644
--- a/net-analyzer/nettop/files/digest-nettop-0.2.3
+++ b/net-analyzer/nettop/files/digest-nettop-0.2.3
@@ -1 +1,3 @@
MD5 e76602717e79a26b0ab15ab6799fb1ef nettop-0.2.3.tar.gz 22797
+RMD160 c3c52ac98f3507046af9c62fad93e9abb3af76cd nettop-0.2.3.tar.gz 22797
+SHA256 4dbb2bdb506c4a5a49d67fbd7bcc860008a881abe55271cf3651316620143556 nettop-0.2.3.tar.gz 22797
diff --git a/net-analyzer/nettop/files/nettop.c.patch b/net-analyzer/nettop/files/nettop.c.patch
index 647f8a430edd..227611c4ceb4 100644
--- a/net-analyzer/nettop/files/nettop.c.patch
+++ b/net-analyzer/nettop/files/nettop.c.patch
@@ -1,6 +1,45 @@
---- nettop.c.orig 2004-11-22 19:06:23.648845592 +0200
-+++ nettop.c 2004-11-22 19:06:38.166638552 +0200
-@@ -361,6 +361,7 @@
+--- nettop.c.orig 2006-07-08 23:20:56.000000000 +1000
++++ nettop.c 2006-07-08 23:25:09.000000000 +1000
+@@ -70,6 +70,7 @@
+ #include <time.h>
+ #include <stdlib.h>
+ #include <netdb.h>
++#include <string.h>
+
+ #include "node.h"
+ #include "ent.h"
+@@ -216,22 +217,26 @@
+ }
+ }
+
+- ether.count = ether.size = (int) ether.l = (int) ether.r = 0;
++ ether.count = ether.size = 0;
++ ether.l = ether.r = 0;
+ ether.type = -1;
+ for (i = 0; i < HISTORY_SIZE; i++)
+ ether.size_h[i] = 0;
+
+- ip.count = ip.size = (int) ip.l = (int) ip.r = 0;
++ ip.count = ip.size = 0;
++ ip.l = ip.r = 0;
+ ip.type = -1;
+ for (i = 0; i < HISTORY_SIZE; i++)
+ ip.size_h[i] = 0;
+
+- tcp.count = tcp.size = (int) tcp.l = (int) tcp.r = 0;
++ tcp.count = tcp.size = 0;
++ tcp.l = tcp.r = 0;
+ tcp.type = -1;
+ for (i = 0; i < HISTORY_SIZE; i++)
+ tcp.size_h[i] = 0;
+
+- udp.count = udp.size = (int) udp.l = (int) udp.r = 0;
++ udp.count = udp.size = 0;
++ udp.l = udp.r = 0;
+ udp.type = -1;
+ for (i = 0; i < HISTORY_SIZE; i++)
+ udp.size_h[i] = 0;
+@@ -361,6 +366,7 @@
}
break;
default:
diff --git a/net-analyzer/nettop/nettop-0.2.3.ebuild b/net-analyzer/nettop/nettop-0.2.3.ebuild
index d147a7628bb1..893896b6dd0c 100644
--- a/net-analyzer/nettop/nettop-0.2.3.ebuild
+++ b/net-analyzer/nettop/nettop-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3.ebuild,v 1.13 2006/02/15 23:30:09 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3.ebuild,v 1.14 2006/07/08 13:28:30 dragonheart Exp $
inherit eutils
@@ -17,9 +17,13 @@ KEYWORDS="amd64 ppc sparc x86"
DEPEND="sys-libs/slang
net-libs/libpcap"
-src_compile() {
- epatch ${FILESDIR}/nettop.c.patch
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/nettop.c.patch
+}
+src_compile() {
local myconf
myconf="--prefix=/usr"
./configure ${myconf} || die