summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild')
-rw-r--r--net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild b/net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild
new file mode 100644
index 000000000000..cee7676c3ec8
--- /dev/null
+++ b/net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-scanner/openvas-scanner-4.0.3.ebuild,v 1.1 2014/09/28 15:40:44 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils systemd
+
+DESCRIPTION="A remote security scanner for Linux (openvas-scanner)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1726/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-7.0.4
+ !net-analyzer/openvas-plugins
+ !net-analyzer/openvas-server"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/cmake"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README
+ newinitd "${FILESDIR}"/openvassd.init openvassd
+ systemd_newtmpfilesd "${FILESDIR}"/openvassd.tmpfiles.d openvassd.conf
+ systemd_dounit "${FILESDIR}"/openvassd.service
+}
+
+pkg_postinst() {
+ elog "To use openvassd, you first need to:"
+ elog "1. Call 'openvas-nvt-sync' to download/update plugins"
+ elog "2. Call 'openvas-mkcert' to generate a server certificate"
+}