summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild')
-rw-r--r--net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild b/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild
new file mode 100644
index 000000000000..c6eb62237817
--- /dev/null
+++ b/net-analyzer/xtraceroute/xtraceroute-0.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <george@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="neat graphical traceroute displaying route on the globe"
+SRC_URI="http://www.dtek.chalmers.se/~d3august/xt/dl/${P}.tar.gz
+ http://www.dtek.chalmers.se/~d3august/xt/dl/ndg_files.tar.gz"
+HOMEPAGE="http://www.dtek.chalmers.se/~d3august/xt/"
+SLOT="0"
+
+DEPEND="x11-base/xfree
+ =x11-libs/gtk+-1.2*
+ net-misc/traceroute
+ <x11-libs/gtkglarea-1.99.0
+ media-libs/gdk-pixbuf
+ net-misc/host"
+
+RDEPEND="${DEPEND}"
+
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-host=/usr/bin/hostx \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+ #make || die
+}
+
+src_install () {
+ #make DESTDIR=${D} install || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+
+ #Install NDG loc database
+ cd ${D}/usr/share/xtraceroute/
+ unpack "ndg_files.tar.gz"
+}