summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/iptraf/files/digest-iptraf-2.4.01
-rw-r--r--net-analyzer/iptraf/iptraf-2.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/iptraf/files/digest-iptraf-2.4.0 b/net-analyzer/iptraf/files/digest-iptraf-2.4.0
new file mode 100644
index 000000000000..373362190e79
--- /dev/null
+++ b/net-analyzer/iptraf/files/digest-iptraf-2.4.0
@@ -0,0 +1 @@
+MD5 becb2fbaef1e387a5339f92520af60e9 iptraf-2.4.0.tar.gz
diff --git a/net-analyzer/iptraf/iptraf-2.4.0.ebuild b/net-analyzer/iptraf/iptraf-2.4.0.ebuild
new file mode 100644
index 000000000000..f8e356aa33e5
--- /dev/null
+++ b/net-analyzer/iptraf/iptraf-2.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bryce Porter <x86@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="IPTraf is an ncurses-based IP LAN monitor"
+SRC_URI="ftp://ftp.cebu.mozcom.com/pub/linux/net/${A}"
+HOMEPAGE="http://cebu.mozcom.com/riker/iptraf/"
+
+DEPEND=">=sys-libs/ncurses-5.2-r1"
+
+src_compile() {
+ cd src
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:$CFLAGS:g" \
+ -e "s:/var/local/iptraf:/var/lib/iptraf:" \
+ Makefile.orig >Makefile
+ try make clean all
+}
+
+src_install() {
+
+ dobin src/{iptraf,cfconv,rvnamed}
+ dodoc COPYING FAQ README* CHANGES RELEASE-NOTES
+ doman Documentation/*.8
+ docinto html
+ dodoc Documentation/*.{gif,html}
+ dodir /var/{lib,run,log}/iptraf
+}