summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.6.3.ebuild55
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.7.2.ebuild61
3 files changed, 124 insertions, 1 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 55d6c40c4719..ba96e274a101 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.54 2015/02/12 18:14:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.55 2015/05/18 18:01:31 swegener Exp $
+
+*pdns-recursor-3.7.2 (18 May 2015)
+*pdns-recursor-3.6.3 (18 May 2015)
+
+ 18 May 2015; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.6.3.ebuild,
+ +pdns-recursor-3.7.2.ebuild:
+ Version bump, security bug #547706.
*pdns-recursor-3.7.1 (12 Feb 2015)
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.6.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.6.3.ebuild
new file mode 100644
index 000000000000..fce67ca65437
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.6.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.6.3.ebuild,v 1.1 2015/05/18 18:01:31 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake \
+ LOCALSTATEDIR=/var/lib/powerdns \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.7.2.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.7.2.ebuild
new file mode 100644
index 000000000000..053e51d5fb4f
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.7.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.7.2.ebuild,v 1.1 2015/05/18 18:01:31 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)" \
+ ./configure
+}
+
+src_compile() {
+ emake \
+ LOCALSTATEDIR=/var/lib/powerdns \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}