summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog12
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.2.9.200704016
-rw-r--r--net-firewall/ipset/ipset-2.2.9.20070401.ebuild46
3 files changed, 62 insertions, 2 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index a415b2827616..1491f115cf93 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-firewall/ipset
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.8 2006/05/25 06:00:32 robbat2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.9 2007/04/10 10:12:08 robbat2 Exp $
+
+*ipset-2.2.9.20070401 (10 Apr 2007)
+
+ 10 Apr 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +ipset-2.2.9.20070401.ebuild:
+ New version from upstream, bug #173218. Please note that while this version
+ will compile without a patched kernel, you still need a patched kernel to
+ use it!.
*ipset-2.2.9.20060508 (25 May 2006)
diff --git a/net-firewall/ipset/files/digest-ipset-2.2.9.20070401 b/net-firewall/ipset/files/digest-ipset-2.2.9.20070401
new file mode 100644
index 000000000000..b53a795bdca9
--- /dev/null
+++ b/net-firewall/ipset/files/digest-ipset-2.2.9.20070401
@@ -0,0 +1,6 @@
+MD5 cdac11a1c348569f1d288bb18701ed7a ipset-20070401.tar.bz2 28279
+RMD160 a51faccf276b5c90a83de1e3a0c5af9d2a93975e ipset-20070401.tar.bz2 28279
+SHA256 0a0c8b96c979148d652bc4b9b6ce601144abecc8c3aceba50f898c58edab1c90 ipset-20070401.tar.bz2 28279
+MD5 da7d15be3b58649892148971b2bfdae7 patch-o-matic-ng-20070401.tar.bz2 142585
+RMD160 34e5c2ad672b7384867d2953bc889c9526ebb754 patch-o-matic-ng-20070401.tar.bz2 142585
+SHA256 8176cfdc36bcf015a2a662589e96bdf23d85240c8ef1f14cad76eb08777700f0 patch-o-matic-ng-20070401.tar.bz2 142585
diff --git a/net-firewall/ipset/ipset-2.2.9.20070401.ebuild b/net-firewall/ipset/ipset-2.2.9.20070401.ebuild
new file mode 100644
index 000000000000..5647dc9fb49a
--- /dev/null
+++ b/net-firewall/ipset/ipset-2.2.9.20070401.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.2.9.20070401.ebuild,v 1.1 2007/04/10 10:12:08 robbat2 Exp $
+
+inherit eutils
+
+MY_PV="${PV/2.2.9.}"
+MY_P="${PN}-${MY_PV}"
+MY_P_POM="patch-o-matic-ng-${MY_PV}"
+DESCRIPTION="IPset userspace tool for iptables, successor to ippool."
+HOMEPAGE="http://ipset.netfilter.org/"
+SRC_URI="http://ftp.netfilter.org/pub/ipset/snapshot/${MY_P}.tar.bz2
+ http://ftp.netfilter.org/pub/patch-o-matic-ng/snapshot/${MY_P_POM}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+RDEPEND=">=net-firewall/iptables-1.3"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ myconf="${myconf} KERNEL_DIR=${WORKDIR}/${MY_P_POM}/patchlets/set/linux-2.6"
+ export myconf
+}
+
+src_compile() {
+ src_defs
+ emake COPT_FLAGS="${CFLAGS}" ${myconf} || die "failed to build"
+}
+
+src_install() {
+ src_defs
+ emake DESTDIR="${D}" ${myconf} install || die "failed to package"
+}
+
+pkg_postinst() {
+ elog "To use ${PF} you must have the ip_set kernel module compiled!"
+}