summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/shorewall/shorewall-1.3.9b.ebuild')
-rw-r--r--net-firewall/shorewall/shorewall-1.3.9b.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-firewall/shorewall/shorewall-1.3.9b.ebuild b/net-firewall/shorewall/shorewall-1.3.9b.ebuild
new file mode 100644
index 000000000000..44341a2500e9
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-1.3.9b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /home/cvsroot/gentoo-x86/net-misc/shorewall/shorewall-1..3.9b.ebuild
+
+DESCRIPTION="Full state iptables firewall"
+SRC_URI="http://www.shorewall.net/pub/shorewall/${P}.tgz"
+HOMEPAGE="http://www.shorewall.net/"
+
+LICENSE="GPL"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-apps/iptables
+ sys-apps/iproute"
+
+src_install() {
+ dodir /etc/init.d
+ dodir /var/state
+ PREFIX=${D} ./install.sh || die
+ rm -f ${D}/usr/lib/shorewall/firewall
+ cp ${D}/etc/init.d/shorewall ${D}/usr/lib/shorewall/firewall
+ rm -rf ${D}/etc/init.d
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/shorewall shorewall
+}
+
+pkg_postinst() {
+ einfo "Read the documentatition from http://www.shorewall.net/"
+ einfo "and edit the files in /etc/shorewall before starting the firewall"
+ echo
+}