summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.4.10a1
-rw-r--r--net-ftp/lftp/lftp-2.4.10a.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/digest-lftp-2.4.10a b/net-ftp/lftp/files/digest-lftp-2.4.10a
new file mode 100644
index 000000000000..1733954957b6
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.4.10a
@@ -0,0 +1 @@
+MD5 f8f9864b6e07e682b8b8770344193636 lftp-2.4.10a.tar.bz2 1105326
diff --git a/net-ftp/lftp/lftp-2.4.10a.ebuild b/net-ftp/lftp/lftp-2.4.10a.ebuild
new file mode 100644
index 000000000000..06d64ee71404
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.4.10a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.4.10a.ebuild,v 1.1 2002/03/28 12:42:16 spider Exp $
+
+DESCRIPTION="Groovy little ftp client"
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${P}.tar.bz2"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+DEPEND="${RDEPEND} nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ #hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}