summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lukemftp/lukemftp-1.5-r3.ebuild')
-rw-r--r--net-ftp/lukemftp/lukemftp-1.5-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild b/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild
new file mode 100644
index 000000000000..808171d72046
--- /dev/null
+++ b/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2000-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lukemftp/lukemftp-1.5-r3.ebuild,v 1.1 2001/11/15 12:55:05 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="NetBSD FTP client with several advanced features"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Adds a command line option: -s, which produces clean, informative output.
+ # Shows progess status, ETA, transfer speed, no server responses or login messages.
+ # ~woodchip
+ cp src/main.c src/main.orig
+ sed -e "s/Aadefgino:pP:r:RtT:u:vV/Aadefgino:pP:r:RstT:u:vV/" \
+ -e "s/case 't'/case 's':\n\t\t\tverbose = 0;\n\t\t\tprogress = 1;\n\t\t\tbreak;\n\n\t\t&/" \
+ src/main.orig > src/main.c
+
+ # And now we need to patch some stuff (achim)
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ local myconf
+ use ipv6 || myconf="${myconf} --disable-ipv6"
+
+ ./configure --host=${CHOST} --prefix=/usr --enable-editcomplete ${myconf}
+ assert ; make ; assert "compile problem :("
+}
+
+src_install() {
+ dodoc COPYING ChangeLog README* THANKS NEWS
+ newbin src/ftp lukemftp
+ newman src/ftp.1 lukemftp.1
+
+ if [ ! -e /usr/bin/ftp ]; then
+ cd ${D}/usr/bin
+ ln -s lukemftp ftp
+ fi
+}