summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/ncftp/ncftp-3.1.8.ebuild')
-rw-r--r--net-ftp/ncftp/ncftp-3.1.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-ftp/ncftp/ncftp-3.1.8.ebuild b/net-ftp/ncftp/ncftp-3.1.8.ebuild
new file mode 100644
index 000000000000..701b556a6a53
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.1.8.ebuild,v 1.1 2004/08/24 20:42:54 vapier Exp $
+
+inherit eutils
+
+IPV6_P="ncftp-3181-v6-20040728"
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="http://www.ncftp.com/"
+SRC_URI="ftp://ftp.ncftp.com/ncftp/${P}-src.tar.bz2
+ ipv6? ( ftp://ftp.cc.chuo-u.ac.jp/pub/IPv6/kame/misc/${IPV6_P}.diff.gz )"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~s390 ~ppc64 ~macos"
+IUSE="ipv6"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use ipv6 && epatch ${WORKDIR}/${IPV6_P}.diff
+}
+
+src_install() {
+ dodir /usr/share
+ einstall || die
+
+ dodoc README.txt doc/*.txt
+ dohtml doc/html/*.html
+}