summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/leechcraft-azoth')
-rw-r--r--net-im/leechcraft-azoth/ChangeLog8
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-0.5.70.ebuild82
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild6
-rw-r--r--net-im/leechcraft-azoth/metadata.xml1
4 files changed, 94 insertions, 3 deletions
diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
index d8af5364e1a7..f9dd80faa03a 100644
--- a/net-im/leechcraft-azoth/ChangeLog
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/leechcraft-azoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.20 2012/05/23 19:02:17 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.21 2012/06/01 05:12:50 maksbotan Exp $
+
+*leechcraft-azoth-0.5.70 (01 Jun 2012)
+
+ 01 Jun 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-azoth-0.5.70.ebuild, leechcraft-azoth-9999.ebuild, metadata.xml:
+ Bump LeechCraft to 0.5.70 "Hessian Blade"
23 May 2012; Maxim Koltsov <maksbotan@gentoo.org>
leechcraft-azoth-9999.ebuild:
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.5.70.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.70.ebuild
new file mode 100644
index 000000000000..acb00f6b79cd
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.5.70.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.5.70.ebuild,v 1.1 2012/06/01 05:12:50 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+ +depester +embedmedia +herbicide +hili +isterique +juick +keeso +lastseen
+ +metacontacts media +modnok +nativeemoticons +otroid +p100q +rosenthal
+ +standardstyles +xoox +xtazy +zheet"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit
+ x11-libs/qt-multimedia
+ autoidler? ( x11-libs/libXScrnSaver )
+ astrality? ( net-libs/telepathy-qt )
+ otroid? ( net-libs/libotr )
+ media? ( x11-libs/qt-multimedia )
+ rosenthal? ( app-text/hunspell )
+ xoox? ( >=net-libs/qxmpp-0.3.47[extras] media-libs/speex )
+ xtazy? ( x11-libs/qt-dbus )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )
+ zheet? ( net-libs/libmsn )"
+RDEPEND="${DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ modnok? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable astrality AZOTH_ASTRALITY)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable isterique AZOTH_ISTERIQUE)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable keeso AZOTH_KEESO)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable media MEDIACALLS)
+ $(cmake-utils_use_enable modnok AZOTH_MODNOK)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable otroid AZOTH_OTROID)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xoox AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ $(cmake-utils_use_enable zheet AZOTH_ZHEET)"
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use rosenthal; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
index 0b40045df221..9f9f77e83be8 100644
--- a/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild,v 1.11 2012/05/23 19:02:17 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild,v 1.12 2012/06/01 05:12:50 maksbotan Exp $
EAPI="4"
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS=""
IUSE="debug astrality +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+depester +embedmedia +herbicide +hili +isterique +juick +keeso +lastseen
- +metacontacts +modnok +nativeemoticons +otroid +p100q +rosenthal
+ +metacontacts media +modnok +nativeemoticons +otroid +p100q +rosenthal
+standardstyles +xoox +xtazy +zheet"
DEPEND="~net-misc/leechcraft-core-${PV}
@@ -21,6 +21,7 @@ DEPEND="~net-misc/leechcraft-core-${PV}
autoidler? ( x11-libs/libXScrnSaver )
astrality? ( net-libs/telepathy-qt )
otroid? ( net-libs/libotr )
+ media? ( x11-libs/qt-multimedia )
rosenthal? ( app-text/hunspell )
xoox? ( =net-libs/qxmpp-9999[extras] media-libs/speex )
xtazy? ( x11-libs/qt-dbus )
@@ -57,6 +58,7 @@ src_configure() {
$(cmake-utils_use_enable keeso AZOTH_KEESO)
$(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
$(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable media MEDIACALLS)
$(cmake-utils_use_enable modnok AZOTH_MODNOK)
$(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
$(cmake-utils_use_enable otroid AZOTH_OTROID)
diff --git a/net-im/leechcraft-azoth/metadata.xml b/net-im/leechcraft-azoth/metadata.xml
index c15c6cec2f7e..b5dc02712358 100644
--- a/net-im/leechcraft-azoth/metadata.xml
+++ b/net-im/leechcraft-azoth/metadata.xml
@@ -18,6 +18,7 @@
<flag name="keeso">Build plugin for changing text into SoMEtHInG lIKe THiS</flag>
<flag name="lastseen">Build plugin for client-side recording of the last online/available time</flag>
<flag name="metacontacts">Build plugin for metacontacts support</flag>
+ <flag name="media">Enable media calls</flag>
<flag name="modnok">Build Modnok for in-chat LaTeX formulae rendering</flag>
<flag name="nativeemoticons">Build support for native Azoth's emoticons packs</flag>
<flag name="otroid">Build OTRoid, plugin for the Off-the-Record deniable encryption system</flag>