summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/atheme-services/atheme-services-6.0.8.ebuild')
-rw-r--r--net-irc/atheme-services/atheme-services-6.0.8.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-irc/atheme-services/atheme-services-6.0.8.ebuild b/net-irc/atheme-services/atheme-services-6.0.8.ebuild
index c8a5a48433a9..12e6c43c8077 100644
--- a/net-irc/atheme-services/atheme-services-6.0.8.ebuild
+++ b/net-irc/atheme-services/atheme-services-6.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-6.0.8.ebuild,v 1.1 2011/06/09 04:38:06 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-6.0.8.ebuild,v 1.2 2011/06/12 03:21:12 binki Exp $
EAPI=4
@@ -28,6 +28,13 @@ pkg_setup() {
# overwhelms cc1 with this flag :-(
filter-flags -combine
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-ldflags -nopie
+ fi
+
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
}