summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/inspircd/files/inspircd-2.0.5-r1-fix-make-config.patch')
-rw-r--r--net-irc/inspircd/files/inspircd-2.0.5-r1-fix-make-config.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/net-irc/inspircd/files/inspircd-2.0.5-r1-fix-make-config.patch b/net-irc/inspircd/files/inspircd-2.0.5-r1-fix-make-config.patch
new file mode 100644
index 000000000000..b87b3f72e320
--- /dev/null
+++ b/net-irc/inspircd/files/inspircd-2.0.5-r1-fix-make-config.patch
@@ -0,0 +1,112 @@
+diff -Nur a/docs/inspircd.conf.example b/docs/inspircd.conf.example
+--- a/docs/inspircd.conf.example 2011-06-24 03:21:01.000000000 +0200
++++ b/docs/inspircd.conf.example 2012-03-22 18:22:49.139949317 +0100
+@@ -401,11 +401,11 @@
+
+ # This file has all the information about oper classes, types and o:lines.
+ # You *MUST* edit it.
+-<include file="conf/opers.conf.example">
++<include file="/etc/inspircd/opers.conf.example">
+
+ # This file has all the information about server links and ulined servers.
+ # You *MUST* edit it if you intend to link servers.
+-<include file="conf/links.conf.example">
++<include file="/etc/inspircd/links.conf.example">
+
+ #-#-#-#-#-#-#-#-#-#- MISCELLANEOUS CONFIGURATION -#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -415,7 +415,8 @@
+ # motd - displayed on connect and when a user executes /MOTD
+ # rules - displayed when the user executes /RULES
+ # Modules can also define their own files
+-<files motd="conf/inspircd.motd.example" rules="conf/inspircd.rules.example">
++<files motd="/etc/inspircd/inspircd.motd.example"
++ rules="/etc/inspircd/inspircd.rules.example">
+
+ # Example of an executable file include. Note this will be read on rehash,
+ # not when the command is run.
+@@ -461,7 +462,7 @@
+ # the default of 'inspircd.pid' is used. #
+ # #
+
+-#<pid file="/path/to/inspircd.pid">
++<pid file="/var/run/inspircd/inspircd.pid">
+
+ #-#-#-#-#-#-#-#-#-#-#-#-#- BANLIST LIMITS #-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -629,7 +630,8 @@
+
+ # nouserdns: If enabled, no DNS lookups will be performed on
+ # connecting users. This can save a lot of resources on very busy servers.
+- nouserdns="no">
++ # Set nouserdns to yes as a workaround for CVE-2012-1836.
++ nouserdns="yes">
+
+ #-#-#-#-#-#-#-#-#-#-#-# SECURITY CONFIGURATION #-#-#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -907,7 +909,7 @@
+ # provide almost all the features of InspIRCd. :) #
+ # #
+ # The default does nothing -- we include it for simplicity for you. #
+-<include file="conf/modules.conf.example">
++<include file="/etc/inspircd/modules.conf.example">
+
+ # Here are some pre-built modules.conf files that closely match the
+ # default configurations of some popular IRCd's. You still may want to
+@@ -919,10 +921,10 @@
+ # recommended that you make your own modules file based on modules.conf.example.
+
+ # Settings similar to UnrealIRCd defaults.
+-#<include file="conf/modules/modules.conf.unreal">
++#<include file="/etc/inspircd/modules/modules.conf.unreal">
+
+ # Settings similar to Charybdis IRCd defaults.
+-#<include file="conf/modules/modules.conf.charybdis">
++#<include file="/etc/inspircd/modules/modules.conf.charybdis">
+
+
+ #########################################################################
+diff -Nur a/make/template/main.mk b/make/template/main.mk
+--- a/make/template/main.mk 2011-06-24 03:21:01.000000000 +0200
++++ b/make/template/main.mk 2012-03-22 18:20:21.659950155 +0100
+@@ -54,22 +54,22 @@
+ CXXFLAGS += -D_ALL_SOURCE -I/usr/local/include
+ @ENDIF
+
+-@IFNDEF D
+- D=0
++@IFNDEF DEBUGLEVEL
++ DEBUGLEVEL=0
+ @ENDIF
+
+ DBGOK=0
+-@IFEQ $(D) 0
++@IFEQ $(DEBUGLEVEL) 0
+ CXXFLAGS += -O2 -g1
+ HEADER = std-header
+ DBGOK=1
+ @ENDIF
+-@IFEQ $(D) 1
++@IFEQ $(DEBUGLEVEL) 1
+ CXXFLAGS += -O0 -g3 -Werror
+ HEADER = debug-header
+ DBGOK=1
+ @ENDIF
+-@IFEQ $(D) 2
++@IFEQ $(DEBUGLEVEL) 2
+ CXXFLAGS += -O2 -g3
+ HEADER = debug-header
+ DBGOK=1
+@@ -111,10 +111,10 @@
+ @GNU_ONLY TARGET = modules/$(M:.so=).so
+ @ENDIF
+
+-@IFDEF T
++@IFDEF TGT
+ HEADER =
+ FOOTER = target
+- TARGET = $(T)
++ TARGET = $(TGT)
+ @ENDIF
+
+ @IFEQ $(DBGOK) 0