summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/sic/ChangeLog7
-rw-r--r--net-irc/sic/sic-1.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-irc/sic/ChangeLog b/net-irc/sic/ChangeLog
index 679a5f7b6131..9a755670953a 100644
--- a/net-irc/sic/ChangeLog
+++ b/net-irc/sic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/sic
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.3 2008/07/17 18:48:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.4 2008/08/05 16:57:29 armin76 Exp $
+
+*sic-1.0 (05 Aug 2008)
+
+ 05 Aug 2008; Raúl Porcel <armin76@gentoo.org> +sic-1.0.ebuild:
+ Version bump, new HOMEPAGE
17 Jul 2008; Alexis Ballier <aballier@gentoo.org> sic-0.9.ebuild:
keyword ~x86-fbsd, thanks to Davide Italiano <dav_it@gentoo.org>, bug
diff --git a/net-irc/sic/sic-1.0.ebuild b/net-irc/sic/sic-1.0.ebuild
new file mode 100644
index 000000000000..787803ece82a
--- /dev/null
+++ b/net-irc/sic/sic-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/sic-1.0.ebuild,v 1.1 2008/08/05 16:57:29 armin76 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://www.suckless.org/programs/sic.html"
+SRC_URI="http://code.suckless.org/dl/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e "s/-s //g" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ dodoc README
+}