summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnxml/libnxml-0.18.3.ebuild')
-rw-r--r--net-libs/libnxml/libnxml-0.18.3.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/net-libs/libnxml/libnxml-0.18.3.ebuild b/net-libs/libnxml/libnxml-0.18.3.ebuild
index 1669afdfa7a1..a283b828e894 100644
--- a/net-libs/libnxml/libnxml-0.18.3.ebuild
+++ b/net-libs/libnxml/libnxml-0.18.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.18.3.ebuild,v 1.2 2011/09/26 22:12:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.18.3.ebuild,v 1.3 2011/09/26 22:16:18 radhermit Exp $
-EAPI="2"
+EAPI="4"
DESCRIPTION="A C-library for parsing and writing XML 1.0/1.1 files or streams"
HOMEPAGE="http://www.autistici.org/bakunin/libnxml/doc/"
@@ -11,14 +11,19 @@ SRC_URI="http://www.autistici.org/bakunin/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc examples"
+IUSE="doc examples static-libs"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
src_compile() {
- emake || die "make failed"
+ emake
if use doc; then
ebegin "Creating documentation"
@@ -28,8 +33,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ default
if use doc; then
dohtml doc/html/*
@@ -39,4 +43,6 @@ src_install() {
insinto /usr/share/doc/${PF}/test
doins test/*.c
fi
+
+ find "${D}" -name '*.la' -exec rm -f {} +
}