summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild')
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild
index edbd06e2fe10..fccd32e043ec 100644
--- a/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild,v 1.3 2010/06/16 18:18:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.30.1.ebuild,v 1.4 2010/06/20 14:07:24 ford_prefect Exp $
EAPI="2"
@@ -11,19 +11,21 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="GNOME plugin for libsoup"
HOMEPAGE="http://www.gnome.org/"
-SRC_URI="${SRC_URI//-gnome}"
+SRC_URI="${SRC_URI//-gnome}
+ mirror://gentoo/${MY_P}-build-gir-patches.tar.bz2"
LICENSE="LGPL-2"
SLOT="2.4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-solaris"
# Do NOT build with --disable-debug/--enable-debug=no - gnome2.eclass takes care of that
-IUSE="debug doc"
+IUSE="debug doc +introspection"
RDEPEND="~net-libs/libsoup-${PV}
|| ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 )
net-libs/libproxy
>=gnome-base/gconf-2
- dev-db/sqlite:3"
+ dev-db/sqlite:3
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9
dev-util/gtk-doc-am
@@ -36,6 +38,7 @@ DOCS="AUTHORS NEWS README"
pkg_setup() {
G2CONF="${G2CONF}
--disable-static
+ $(use_enable introspection)
--with-libsoup-system
--with-gnome"
}
@@ -46,6 +49,11 @@ src_prepare() {
# No patch to prevent having to eautoreconf
sed -e 's/\(test.*\)==/\1=/g' -i configure.ac configure || die "sed failed"
+ if use introspection; then
+ epatch "${WORKDIR}/${MY_P}-build-gir-1.patch"
+ epatch "${WORKDIR}/${MY_P}-build-gir-2.patch"
+ fi
+
# Use lib present on the system
epatch "${FILESDIR}"/${PN}-2.30.1-system-lib.patch
eautoreconf