summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/loudmouth/loudmouth-1.2.2.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-1.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-1.2.2.ebuild b/net-libs/loudmouth/loudmouth-1.2.2.ebuild
new file mode 100644
index 000000000000..8ac579edabd6
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.2.2.ebuild,v 1.1 2007/05/30 17:03:12 tester Exp $
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://developer.imendio.com/projects/loudmouth/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc ssl debug"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc)"
+}