summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/curl/curl-7.12.0-r2.ebuild')
-rw-r--r--net-misc/curl/curl-7.12.0-r2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/net-misc/curl/curl-7.12.0-r2.ebuild b/net-misc/curl/curl-7.12.0-r2.ebuild
deleted file mode 100644
index 9072a0facbfd..000000000000
--- a/net-misc/curl/curl-7.12.0-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.12.0-r2.ebuild,v 1.11 2005/06/23 01:40:45 agriffis Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit eutils
-
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="x86 ppc sparc ~mips alpha ~arm hppa amd64 ~ppc64 ~s390"
-IUSE="ssl ipv6 ldap"
-
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
- ldap? ( net-nds/openldap )"
-
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-no-fputc.patch
-}
-
-src_compile() {
- econf \
- `use_enable ipv6` \
- `use_enable ldap` \
- `use_with ssl` \
- --enable-http \
- --enable-ftp \
- --enable-gopher \
- --enable-file \
- --enable-dict \
- --enable-manual \
- --enable-telnet \
- --enable-nonblocking \
- --enable-largefile \
- || die
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc LEGAL CHANGES README
- dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-
- # backwards compat link
- dosym libcurl.so.3 /usr/$(get_libdir)/libcurl.so.2
-}