summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/directvnc')
-rw-r--r--net-misc/directvnc/ChangeLog7
-rw-r--r--net-misc/directvnc/directvnc-0.7.6.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/net-misc/directvnc/ChangeLog b/net-misc/directvnc/ChangeLog
index 7cc81f60a157..6325a8b2bbcc 100644
--- a/net-misc/directvnc/ChangeLog
+++ b/net-misc/directvnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/directvnc
# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/ChangeLog,v 1.22 2010/09/03 14:07:46 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/ChangeLog,v 1.23 2010/09/03 15:01:24 s4t4n Exp $
+
+*directvnc-0.7.6 (03 Sep 2010)
+
+ 03 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> +directvnc-0.7.6.ebuild:
+ Version bump. Closes bug #305107.
03 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> directvnc-0.7.5.ebuild,
directvnc-0.7.5-r1.ebuild:
diff --git a/net-misc/directvnc/directvnc-0.7.6.ebuild b/net-misc/directvnc/directvnc-0.7.6.ebuild
new file mode 100644
index 000000000000..a76cedb06f11
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.7.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/directvnc-0.7.6.ebuild,v 1.1 2010/09/03 15:01:25 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://drinkmilk.github.com/directvnc/"
+SRC_URI="http://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="mouse"
+
+RDEPEND="dev-libs/DirectFB
+ >=media-libs/jpeg-6b-r7"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+
+ # Make mouse support optional
+ cd "${S}/src"
+ use mouse || epatch "${FILESDIR}/${PN}-mouse.patch"
+}
+
+src_compile() {
+ econf || die
+
+ # Fix bug #116148, DFBGraphicsDeviceDescription is no longer present in
+ # newer DirectFB version, but the application never uses it :-/
+ local comment_out="DFBCardCapabilities caps;"
+ sed -i -e "s:${comment_out}://${comment_out}:" src/dfb.c
+
+ emake DEBUGFLAGS="${CFLAGS}" AM_LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -rf "${D}/usr/doc"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}