summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog7
-rw-r--r--net-misc/neon/Manifest2
-rw-r--r--net-misc/neon/files/digest-neon-0.24.51
-rw-r--r--net-misc/neon/neon-0.24.5.ebuild32
4 files changed, 41 insertions, 1 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index b79992893a65..5677b392ac0a 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/neon
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.27 2004/04/26 13:21:31 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.28 2004/04/27 08:21:14 pauldv Exp $
+
+*neon-0.24.5 (27 Apr 2004)
+
+ 27 Apr 2004; Paul de Vrieze <pauldv@gentoo.org> +neon-0.24.5.ebuild:
+ New upstream version with SECURITY fixes. Updating is highly recommended
26 Apr 2004; Paul de Vrieze <pauldv@gentoo.org> neon-0.24.4.ebuild:
Mark stable so that subversion can be marked stable
diff --git a/net-misc/neon/Manifest b/net-misc/neon/Manifest
index 912734eaa62e..3c8c8e99653b 100644
--- a/net-misc/neon/Manifest
+++ b/net-misc/neon/Manifest
@@ -5,9 +5,11 @@ MD5 b616f685a16f8e3ea6f85142b6c45127 neon-0.23.9.ebuild 785
MD5 2ae7200538068877dd6268e6a69a3c67 metadata.xml 635
MD5 97fedcf8da146da10f3900603340d0de ChangeLog 4207
MD5 fff098a39763ab92ab9c2cd39aa6425f neon-0.23.8.ebuild 784
+MD5 89f41a02d5455f2b85fc358bc4827fc0 neon-0.24.5.ebuild 954
MD5 89f41a02d5455f2b85fc358bc4827fc0 neon-0.24.4.ebuild 954
MD5 9ea45811212cea8423e1fd38812675ed files/digest-neon-0.23.9 63
MD5 78a022284df1908c3c24448427111e6a files/digest-neon-0.24.2 63
+MD5 97d9fa5100efbc5b63dbea48f7d36cf6 files/digest-neon-0.24.5 63
MD5 5a576942b2663898889c1239a5bec804 files/digest-neon-0.21.3 63
MD5 e6994eafdacea2341c0b293f12a27e4c files/digest-neon-0.23.8 63
MD5 84942fd6f6fe937bf09d9649e6e14436 files/digest-neon-0.24.4 63
diff --git a/net-misc/neon/files/digest-neon-0.24.5 b/net-misc/neon/files/digest-neon-0.24.5
new file mode 100644
index 000000000000..3372468b98fa
--- /dev/null
+++ b/net-misc/neon/files/digest-neon-0.24.5
@@ -0,0 +1 @@
+MD5 69c2a079ea0ab01c6c39e8e01a58c665 neon-0.24.5.tar.gz 599383
diff --git a/net-misc/neon/neon-0.24.5.ebuild b/net-misc/neon/neon-0.24.5.ebuild
new file mode 100644
index 000000000000..1b9c7ecb3ad8
--- /dev/null
+++ b/net-misc/neon/neon-0.24.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.24.5.ebuild,v 1.1 2004/04/27 08:21:14 pauldv Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTTP and WebDAV client library"
+SRC_URI="http://www.webdav.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.webdav.org/neon"
+DEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ zlib? ( sys-libs/zlib )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
+IUSE="ssl zlib expat"
+
+src_compile() {
+ local myc='--enable-shared'
+
+ use ssl && myc="$myc --with-ssl" || myc="$myc --without-ssl"
+ use expat && myc="$myc --with-expat" || myc="$myc --with-xml2"
+ use zlib && myc="$myc --with-zlib" || myc="$myc --without-zlib"
+
+ econf $myc || die "econf failed"
+ emake
+}
+
+src_install () {
+ einstall
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}