summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild')
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
index 8116799df62f..ded635d2edb0 100644
--- a/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild,v 1.5 2004/07/01 09:15:46 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ed2k_hash/ed2k_hash-0.4.0.ebuild,v 1.6 2004/09/03 00:29:22 malc Exp $
DESCRIPTION="Tool for generating eDonkey2000 links"
HOMEPAGE="http://ed2k-tools.sourceforge.net/${PN}.shtml"
@@ -8,10 +8,17 @@ RESTRICT="nomirror"
SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86 ppc ~amd64"
IUSE=""
DEPEND="virtual/libc"
+inherit eutils
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${FILESDIR}/ed2k_64bit.patch
+}
+
src_install() {
make install DESTDIR=${D} || die