summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog7
-rw-r--r--net-p2p/gnunet/Manifest4
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.5.41
-rw-r--r--net-p2p/gnunet/gnunet-0.5.4.ebuild47
4 files changed, 56 insertions, 3 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index fa405a52433e..5500cf1000d4 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.7 2003/03/23 10:06:58 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.8 2003/06/16 23:16:34 spider Exp $
+
+*gnunet-0.5.4 (17 Jun 2003)
+
+ 17 Jun 2003; <spider@gentoo.org> gnunet-0.5.4.ebuild:
+ Update, added ipv6 support. added default config.
*gnunet-0.5.2a (23 mar 2003)
diff --git a/net-p2p/gnunet/Manifest b/net-p2p/gnunet/Manifest
index 5da9ccc606e6..d872b7ab4f8b 100644
--- a/net-p2p/gnunet/Manifest
+++ b/net-p2p/gnunet/Manifest
@@ -3,8 +3,8 @@ MD5 87a28f8bfb348b061c531a3bdbca8884 gnunet-0.4.2.ebuild 1117
MD5 94e70847eb6c1f77c4060c6e5bfe8dbb gnunet-0.5.1a.ebuild 972
MD5 ea484e7b68f8a6a5547f97d2c210fc6e gnunet-0.4.4.ebuild 1116
MD5 8fd9f497e54af15d39dbbf749c85e29b gnunet-0.4.6.ebuild 1086
-MD5 5abb55268e66047d0aaa9c6aef2416b0 gnunet-0.5.4.ebuild 972
-MD5 e9488992f8512a838f655eeeb974acfa ChangeLog 1488
+MD5 00b0e74eaf4793b9afa3e7c00d67ddd7 gnunet-0.5.4.ebuild 1208
+MD5 bda93bc721907a1bbdb0851377cbadd2 ChangeLog 1625
MD5 7664f3e5104494e1adac6a1509e14ad7 files/digest-gnunet-0.5.1a 66
MD5 ac97b3cabe2be122a2a6f6bd693ff30e files/digest-gnunet-0.5.2a 66
MD5 cd954d086aa8704dece0dd0b302f07f2 files/digest-gnunet-0.4.2 65
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.5.4 b/net-p2p/gnunet/files/digest-gnunet-0.5.4
new file mode 100644
index 000000000000..6cc2dc92d190
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.5.4
@@ -0,0 +1 @@
+MD5 885476e1234d5cb71bc0fa044e868e49 GNUnet-0.5.4.tar.bz2 664164
diff --git a/net-p2p/gnunet/gnunet-0.5.4.ebuild b/net-p2p/gnunet/gnunet-0.5.4.ebuild
new file mode 100644
index 000000000000..3d589aeb95d7
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.5.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.5.4.ebuild,v 1.1 2003/06/16 23:16:34 spider Exp $
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.2.0"
+
+
+src_compile () {
+ local myconf
+ use ipv6 && myconf="--enable-ipv6" || myconf=" --disable-ipv6"
+ econf ${myconf}
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+ dodir /etc
+ cp contrib/gnunet.conf.root ${D}/etc/gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bug"
+ einfo ""
+ einfo "now copy an appropriate config file from"
+ einfo "/usr/share/doc/${P}/contrib"
+ einfo "to ~/.gnunet/gnunet.conf"
+ einfo ""
+}