summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/opendchub/opendchub-0.7.14-r1.ebuild')
-rw-r--r--net-p2p/opendchub/opendchub-0.7.14-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/opendchub/opendchub-0.7.14-r1.ebuild b/net-p2p/opendchub/opendchub-0.7.14-r1.ebuild
new file mode 100644
index 000000000000..1faffc627663
--- /dev/null
+++ b/net-p2p/opendchub/opendchub-0.7.14-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/opendchub/opendchub-0.7.14-r1.ebuild,v 1.1 2004/08/23 21:09:54 squinky86 Exp $
+
+inherit eutils
+
+DESCRIPTION="hub software for Direct Connect"
+HOMEPAGE="http://opendchub.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="perl"
+
+DEPEND="virtual/libc
+ perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/opendchub-gentoo.patch
+ epatch ${FILESDIR}/${PV}-telnet.patch
+}
+
+src_compile() {
+ econf `use_enable perl` || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+ if use perl ; then
+ exeinto /usr/bin
+ doexe ${FILESDIR}/opendchub_setup.sh
+ dodir /usr/share/opendchub/scripts
+ insinto /usr/share/opendchub/scripts
+ doins Samplescripts/*
+ fi
+ dodoc Documentation/*
+}
+
+pkg_postinst() {
+ if use perl ; then
+ einfo
+ einfo "To set up perl scripts for opendchub to use, please run"
+ einfo "opendchub_setup.sh as the user you will be using opendchub as."
+ einfo
+ fi
+}