summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/transmission/files/0002-Add-qt-config-to-make-qmake-aware-about-.-configure-.patch')
-rw-r--r--net-p2p/transmission/files/0002-Add-qt-config-to-make-qmake-aware-about-.-configure-.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-p2p/transmission/files/0002-Add-qt-config-to-make-qmake-aware-about-.-configure-.patch b/net-p2p/transmission/files/0002-Add-qt-config-to-make-qmake-aware-about-.-configure-.patch
new file mode 100644
index 000000000000..eeef9d87e8a2
--- /dev/null
+++ b/net-p2p/transmission/files/0002-Add-qt-config-to-make-qmake-aware-about-.-configure-.patch
@@ -0,0 +1,72 @@
+From f742757aa1e4419d2d5cb77425bc6b694e511ad6 Mon Sep 17 00:00:00 2001
+From: Peter Volkov <pva@gentoo.org>
+Date: Thu, 16 Jun 2011 12:48:11 +0400
+Subject: [PATCH 2/3] Add qt/config to make qmake aware about ./configure results. This simplifies use of system third-party tools. Fixes build issue caused by ordering of make/qmake run: bugs.gentoo.org/368523.
+
+---
+ configure.ac | 5 ++++-
+ qt/config.in | 1 +
+ qt/qtr.pro | 6 +++---
+ 3 files changed, 8 insertions(+), 4 deletions(-)
+ create mode 100644 qt/config.in
+
+diff --git a/configure.ac b/configure.ac
+index 7f17a55..f4ec7d1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -225,6 +225,7 @@ if test "x$want_utp" = "xyes" ; then
+ if test "x$CXX" != "x" ; then
+ LIBUTP_CFLAGS="-I\$(top_srcdir)/third-party/"
+ LIBUTP_LIBS="\$(top_builddir)/third-party/libutp/libutp.a $libutp_extra_libs"
++ LIBUTP_LIBS_QT="\$\${TRANSMISSION_TOP}/third-party/libutp/libutp.a $libutp_extra_libs"
+ AC_DEFINE([WITH_UTP],[1])
+ build_utp="yes"
+ else
+@@ -233,6 +234,7 @@ if test "x$want_utp" = "xyes" ; then
+ fi
+ AC_SUBST(LIBUTP_CFLAGS)
+ AC_SUBST(LIBUTP_LIBS)
++AC_SUBST(LIBUTP_LIBS_QT)
+ AM_CONDITIONAL([BUILD_UTP],[test "x$build_utp" = "xyes"])
+ AC_MSG_RESULT([$build_utp])
+
+@@ -505,7 +507,8 @@ AC_CONFIG_FILES([Makefile
+ web/javascript/Makefile
+ web/javascript/jquery/Makefile
+ web/stylesheets/Makefile
+- po/Makefile.in])
++ po/Makefile.in
++ qt/config])
+
+ AC_OUTPUT
+
+diff --git a/qt/config.in b/qt/config.in
+new file mode 100644
+index 0000000..3340d1a
+--- /dev/null
++++ b/qt/config.in
+@@ -0,0 +1 @@
++LIBUTP_LIBS = @LIBUTP_LIBS_QT@
+diff --git a/qt/qtr.pro b/qt/qtr.pro
+index ce138a2..4e28e98 100644
+--- a/qt/qtr.pro
++++ b/qt/qtr.pro
+@@ -16,12 +16,12 @@ QT += network
+ PKGCONFIG = fontconfig libcurl openssl libevent
+
+ TRANSMISSION_TOP = ..
++include(config)
++
+ INCLUDEPATH = $${EVENT_TOP}/include $${INCLUDEPATH}
+ INCLUDEPATH += $${TRANSMISSION_TOP}
+ LIBS += $${TRANSMISSION_TOP}/libtransmission/libtransmission.a
+-exists( $${TRANSMISSION_TOP}/third-party/libutp/libutp.a ) {
+- LIBS += $${TRANSMISSION_TOP}/third-party/libutp/libutp.a
+-}
++LIBS += $${LIBUTP_LIBS}
+ LIBS += $${TRANSMISSION_TOP}/third-party/dht/libdht.a
+ LIBS += $${TRANSMISSION_TOP}/third-party/miniupnp/libminiupnp.a
+ LIBS += $${TRANSMISSION_TOP}/third-party/libnatpmp/libnatpmp.a
+--
+1.7.3.4
+