summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/zuul/zuul-1.1.2.ebuild')
-rw-r--r--net-p2p/zuul/zuul-1.1.2.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-p2p/zuul/zuul-1.1.2.ebuild b/net-p2p/zuul/zuul-1.1.2.ebuild
index a6ce57cb704e..8b6b42b28d7d 100644
--- a/net-p2p/zuul/zuul-1.1.2.ebuild
+++ b/net-p2p/zuul/zuul-1.1.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/zuul/zuul-1.1.2.ebuild,v 1.2 2004/02/23 13:05:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/zuul/zuul-1.1.2.ebuild,v 1.3 2004/04/20 21:05:05 squinky86 Exp $
+
+inherit webapp-apache
-HOSTNAME=`hostname`
DESCRIPTION="Zuul is yet another PHP front-end for mldonkey. It will allow full access to all the features of mldonkey including starting/viewing downloads, viewing uploads, viewing servers, and setting all the options."
HOMEPAGE="http://zuul.sourceforge.net"
@@ -21,12 +22,10 @@ DEPEND=""
S="${WORKDIR}/${PN}-${MY_PV}"
-HTTPD_ROOT="`grep -s '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
-[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep -s '^DocumentRoot' /etc/apache2/conf/apache2.conf | cut -d\ -f2`"
-[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
-HTTPD_USER="apache"
-HTTPD_GROUP="apache"
-
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-pkg_setup "${NO_WEBSERVER}"
+}
src_compile() {
echo "Nothing to compile"