summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild')
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild
new file mode 100644
index 000000000000..454b40aa825f
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20031018.ebuild,v 1.1 2003/12/31 12:49:03 lanius Exp $
+
+inherit perl-module
+
+MY_P=${P/3.0./3.0-}
+
+DESCRIPTION="Foomatic printer database engine"
+HOMEPAGE="http://www.linuxprinting.org/foomatic"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa amd64"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-libs/libxml2
+ net-misc/wget
+ net-ftp/curl
+ net-print/foomatic-filters"
+
+src_compile() {
+ epatch ${FILESDIR}/perl-module.diff
+ econf
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ # install perl modules
+ cd lib
+ perl-module_src_prep
+ perl-module_src_compile
+ perl-module_src_test
+ perl-module_src_install
+}