summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild')
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild
new file mode 100644
index 000000000000..562636a525e5
--- /dev/null
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-ppds/foomatic-db-ppds-3.0.20070508.ebuild,v 1.1 2008/05/07 23:33:03 tgurr Exp $
+
+inherit eutils versionator
+
+MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
+DESCRIPTION="linuxprinting.org PPD files for postscript printers"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://gentooexperimental.org/~calchan/distfiles/${MY_P}.tar.gz
+ http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/Makefile.in-20070508.patch"
+ # scripts do not belong to this package, no translated ppds, no html and text files
+ rm -r db/source/PPD/{*.sh,Kyocera/{de,es,fr,it,pt,*.htm,*.txt}}
+}
+
+src_compile() {
+ econf || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}