summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog7
-rw-r--r--net-print/splix/files/digest-splix-1.0.23
-rw-r--r--net-print/splix/splix-1.0.2.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index fc1573109ba9..ec1b0e7b77b5 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/splix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.8 2007/10/14 18:31:30 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.9 2007/10/27 12:07:43 wschlich Exp $
+
+*splix-1.0.2 (27 Oct 2007)
+
+ 27 Oct 2007; Wolfram Schlich <wschlich@gentoo.org> +splix-1.0.2.ebuild:
+ version bump, fixes segfaults due to overly large documents
14 Oct 2007; Wolfram Schlich <wschlich@gentoo.org> splix-1.0.1_p1.ebuild:
add missing cupsddk dep
diff --git a/net-print/splix/files/digest-splix-1.0.2 b/net-print/splix/files/digest-splix-1.0.2
new file mode 100644
index 000000000000..f2cc392501a4
--- /dev/null
+++ b/net-print/splix/files/digest-splix-1.0.2
@@ -0,0 +1,3 @@
+MD5 2bc6f0dbc4ba8eb6367e7ba240ea5836 splix-1.0.2.tar.bz2 37778
+RMD160 dcff8cf9ceca0810bc25adaa39da67b38652a2aa splix-1.0.2.tar.bz2 37778
+SHA256 fe346aa87d2023c7677dece720e2840e693184dad85b55a8d19912685424540e splix-1.0.2.tar.bz2 37778
diff --git a/net-print/splix/splix-1.0.2.ebuild b/net-print/splix/splix-1.0.2.ebuild
new file mode 100644
index 000000000000..b6f1ae3a8b09
--- /dev/null
+++ b/net-print/splix/splix-1.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-1.0.2.ebuild,v 1.1 2007/10/27 12:07:43 wschlich Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_p/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ net-print/cupsddk"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.1_p1-fix-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.0.1_p1-fix-nocolor-segfault.patch
+ epatch "${FILESDIR}"/${PN}-1.0.1_p1-fix-ppd-parallel-build.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ CUPSFILTERDIR="$(cups-config --serverbin)/filter"
+ CUPSPPDDIR="$(cups-config --datadir)/model"
+
+ dodir "${CUPSFILTERDIR}"
+ dodir "${CUPSPPDDIR}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ebeep 5
+ ewarn ""
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+ ewarn ""
+}