summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild')
-rw-r--r--net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild b/net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild
new file mode 100644
index 000000000000..a0ff107c11cb
--- /dev/null
+++ b/net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hackrf-tools/hackrf-tools-2013.06.1.ebuild,v 1.1 2013/06/11 03:06:20 zerochaos Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/hackrf-tools"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/hackrf-tools"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/libusb:1
+ net-libs/libhackrf:="
+RDEPEND="${DEPEND}"