summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hackrf-tools/hackrf-tools-9999.ebuild')
-rw-r--r--net-wireless/hackrf-tools/hackrf-tools-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
index 672e3df51b36..6c99f18f8186 100644
--- a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
+++ b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild,v 1.1 2013/06/07 14:40:46 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild,v 1.2 2013/06/11 03:06:20 zerochaos Exp $
EAPI=5
-inherit cmake-utils git-2
+inherit cmake-utils
DESCRIPTION="library for communicating with HackRF SDR platform"
-HOMEPAGE="https://github.com/mossmann/hackrf"
-EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
-SRC_URI=""
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/hackrf-tools"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/hackrf-tools"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-#KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="virtual/libusb:1
- net-libs/libhackrf"
+ net-libs/libhackrf:="
RDEPEND="${DEPEND}"
-
-EGIT_SOURCEDIR="${WORKDIR}/${P}"
-S="${WORKDIR}/${P}/host/hackrf-tools"