summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hostapd/hostapd-0.7.3.ebuild')
-rw-r--r--net-wireless/hostapd/hostapd-0.7.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-wireless/hostapd/hostapd-0.7.3.ebuild b/net-wireless/hostapd/hostapd-0.7.3.ebuild
index 535baf29fe54..73b095223e04 100644
--- a/net-wireless/hostapd/hostapd-0.7.3.ebuild
+++ b/net-wireless/hostapd/hostapd-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.7.3.ebuild,v 1.5 2011/07/13 12:19:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.7.3.ebuild,v 1.6 2011/09/09 22:56:50 gurligebis Exp $
EAPI="2"
@@ -86,7 +86,6 @@ src_configure() {
einfo " nl80211 driver enabled"
echo "CONFIG_DRIVER_NL80211=y" >> ${CONFIG}
- echo "CFLAGS += -I/usr/include/netlink" >> ${CONFIG}
echo "LIBS += -L/usr/lib" >> ${CONFIG}
# misc
@@ -108,6 +107,11 @@ src_configure() {
echo "CONFIG_NO_STDOUT_DEBUG=y" >> ${CONFIG}
fi
+ # If we are using libnl 2.0 and above, enable support for it
+ if has_version ">=dev-libs/libnl-2.0"; then
+ echo "CONFIG_LIBNL20=y" >> .config
+ fi
+
# TODO: Add support for BSD drivers
default_src_configure