summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/lynx')
-rw-r--r--net-www/lynx/ChangeLog7
-rw-r--r--net-www/lynx/lynx-2.8.4.1c.ebuild31
-rw-r--r--net-www/lynx/lynx-2.8.4a-r4.ebuild31
3 files changed, 44 insertions, 25 deletions
diff --git a/net-www/lynx/ChangeLog b/net-www/lynx/ChangeLog
index 33f365f779bb..c58fb08f3389 100644
--- a/net-www/lynx/ChangeLog
+++ b/net-www/lynx/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-www/lynx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.7 2002/08/26 08:48:57 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.8 2002/08/29 22:37:21 seemant Exp $
*lynx-2.8.4.1c (26 Aug 2002)
+ 28 Aug 2002; Seemant Kulleen <seemant@gentoo.org> lynx-2.8.4.1c.ebuild
+ lynx-2.8.4a-r4.ebuild :
+
+ PROVIDE=virtual/textbrowser
+
26 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> lynx-2.8.4.1c.ebuild :
Updated to latest patchlevel to fix CRLF injection. More info availabe
at http://online.securityfocus.com/archive/1/288054/2002-08-16/2002-08-22/0
diff --git a/net-www/lynx/lynx-2.8.4.1c.ebuild b/net-www/lynx/lynx-2.8.4.1c.ebuild
index f45b832a6a51..a55afbaff8da 100644
--- a/net-www/lynx/lynx-2.8.4.1c.ebuild
+++ b/net-www/lynx/lynx-2.8.4.1c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4.1c.ebuild,v 1.1 2002/08/26 08:48:57 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4.1c.ebuild,v 1.2 2002/08/29 22:37:21 seemant Exp $
MY_PV=${PV/.1c/rel.1}
S=${WORKDIR}/${PN}2-8-4
@@ -14,12 +14,12 @@ KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/zlib-1.1.3
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
+PROVIDE="virtual/textbrowser"
src_unpack() {
unpack ${PN}${MY_PV}.tar.bz2
@@ -43,12 +43,19 @@ src_compile() {
CFLAGS="${CFLAGS} -DANSI_VARARGS"
- ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
- --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
- --enable-nsl-fork --enable-file-upload --enable-read-eta \
- --enable-libjs --enable-color-style --enable-scrollbar \
- --enable-included-msgs --with-zlib --host=${CHOST} ${myconf}
- assert
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ ${myconf} || die
emake || die "compile problem"
}
diff --git a/net-www/lynx/lynx-2.8.4a-r4.ebuild b/net-www/lynx/lynx-2.8.4a-r4.ebuild
index b0e0dd1da848..24a453e51a6a 100644
--- a/net-www/lynx/lynx-2.8.4a-r4.ebuild
+++ b/net-www/lynx/lynx-2.8.4a-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4a-r4.ebuild,v 1.6 2002/08/16 03:01:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4a-r4.ebuild,v 1.7 2002/08/29 22:37:21 seemant Exp $
S=${WORKDIR}/lynx2-8-4
DESCRIPTION="An excellent console-based web browser with ssl support"
@@ -11,12 +11,12 @@ KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
LICENSE="GPL-2"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/zlib-1.1.3
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
+PROVIDE="virtual/textbrowser"
src_unpack() {
unpack ${A}
@@ -38,12 +38,19 @@ src_compile() {
CFLAGS="${CFLAGS} -DANSI_VARARGS"
- ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
- --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
- --enable-nsl-fork --enable-file-upload --enable-read-eta \
- --enable-libjs --enable-color-style --enable-scrollbar \
- --enable-included-msgs --with-zlib --host=${CHOST} ${myconf}
- assert
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ ${myconf} || die
emake || die "compile problem"
}