summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild')
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild218
1 files changed, 109 insertions, 109 deletions
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild
index 03bdf5e803ac..4ccd076e1a6d 100644
--- a/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild,v 1.8 2003/08/03 09:09:07 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r7.ebuild,v 1.9 2003/09/06 01:54:09 msterret Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils
@@ -19,28 +19,28 @@ LICENSE="MPL-1.1 | NPL-1.1"
IUSE="java gtk2 ipv6 gnome moznoxft"
RDEPEND="virtual/x11
- >=dev-libs/libIDL-0.8.0
- >=gnome-base/ORBit-0.5.10-r1
- virtual/xft
- >=sys-libs/zlib-1.1.4
- >=media-libs/jpeg-6b
- >=media-libs/libmng-1.0.0
- >=media-libs/libpng-1.2.1
- >=sys-apps/portage-2.0.36
- dev-libs/expat
- app-arch/zip
- app-arch/unzip
- ( gtk2? >=x11-libs/gtk+-2.1.1 :
- =x11-libs/gtk+-1.2* )
- java? ( virtual/jre )
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
!net-www/mozilla-firebird-bin
!net-www/mozilla-firebird-cvs"
DEPEND="${RDEPEND}
- virtual/glibc
- dev-lang/perl
- java? ( >=dev-java/java-config-0.2.0 )"
-
+ virtual/glibc
+ dev-lang/perl
+ java? ( >=dev-java/java-config-0.2.0 )"
+
# needed by src_compile() and src_install()
export MOZ_PHOENIX=1
export MOZ_CALENDAR=0
@@ -48,63 +48,63 @@ export MOZ_ENABLE_XFT=1
src_unpack() {
unpack MozillaFirebird-${PV}-source.tar.bz2
-
+
# alpha stubs patch from lfs project.
# <taviso@gentoo.org> (26 Jun 2003)
use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
# Fix build with Linux 2.6
cp ${S}/security/coreconf/Linux2.5.mk ${S}/security/coreconf/Linux2.6.mk
-
+
}
src_compile() {
- local myconf="--disable-composer \
- --with-x \
- --with-system-jpeg \
- --with-system-zlib \
- --with-system-png \
- --with-system-mng \
- --disable-mailnews \
- --disable-calendar \
- --disable-pedantic \
- --disable-svg \
- --enable-mathml \
- --without-system-nspr \
- --enable-nspr-autoconf \
- --enable-xsl \
- --enable-crypto \
- --enable-xinerama=no \
- --with-java-supplement \
- --with-pthreads \
- --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
- --with-user-appdir=.phoenix \
- --disable-jsd \
- --disable-accessibility \
- --disable-tests \
- --disable-debug \
- --disable-dtd-debug \
- --disable-logging \
- --enable-reorder \
- --enable-strip \
- --enable-strip-libs \
- --enable-cpp-rtti \
- --enable-xterm-updates \
- --enable-optimize=-O2 \
- --disable-ldap \
- --disable-toolkit-qt \
- --disable-toolkit-xlib \
- --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
-
- if [ -n "`use gtk2`" ] ; then
- myconf="${myconf} --enable-toolkit-gtk2 \
- --enable-default-toolkit=gtk2 \
- --disable-toolkit-gtk"
- else
- myconf="${myconf} --enable-toolkit-gtk \
- --enable-default-toolkit=gtk \
- --disable-toolkit-gtk2"
- fi
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --enable-optimize=-O2 \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib \
+ --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
if [ -z "`use moznoxft`" ]
then
@@ -142,51 +142,51 @@ src_compile() {
myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
fi
- if [ -n "`use ipv6`" ] ; then
- myconf="${myconf} --enable-ipv6"
- fi
-
- # Crashes on start when compiled with -fomit-frame-pointer
- filter-flags -fomit-frame-pointer
- filter-flags -ffast-math
- append-flags -s -fforce-addr
-
- if [ "$(gcc-major-version)" -eq "3" ]; then
- # Currently gcc-3.2 or older do not work well if we specify "-march"
- # and other optimizations for pentium4.
- if [ "$(gcc-minor-version)" -lt "3" ]; then
- replace-flags -march=pentium4 -march=pentium3
- filter-flags -msse2
- fi
-
- # Enable us to use flash, etc plugins compiled with gcc-2.95.3
- if [ "${ARCH}" = "x86" ]; then
- myconf="${myconf} --enable-old-abi-compat-wrappers"
- fi
- fi
-
- econf ${myconf} || die
-
- edit_makefiles
- emake MOZ_PHOENIX=1 || die
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ filter-flags -ffast-math
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
}
src_install() {
- # Plugin path creation
- PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
- dodir ${PLUGIN_DIR}
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir ${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirebird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
- dodir /usr/lib
- dodir /usr/lib/MozillaFirebird
- cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaFirebird
- #fix permissions
- chown -R root.root ${D}/usr/lib/MozillaFirebird
-
- # Plugin path setup (rescuing the existent plugins)
- src_mv_plugins /usr/lib/MozillaFirebird/plugins
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/MozillaFirebird/plugins
- dobin ${FILESDIR}/MozillaFirebird
+ dobin ${FILESDIR}/MozillaFirebird
# Fix icons to look the same everywhere
insinto /usr/lib/MozillaFirebird/icons
@@ -213,15 +213,15 @@ src_install() {
}
pkg_preinst() {
- # Remove the old plugins dir
- pkg_mv_plugins /usr/lib/MozillaFirebird/plugins
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/MozillaFirebird/plugins
}
pkg_postinst() {
export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaFirebird"
- # Needed to update the run time bindings for REGXPCOM
+ # Needed to update the run time bindings for REGXPCOM
# (do not remove next line!)
env-update
# Register Components and Chrome