summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild')
-rw-r--r--net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild b/net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild
new file mode 100644
index 000000000000..1d522e36a4ba
--- /dev/null
+++ b/net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-launcher/mozilla-launcher-1.7-r1.ebuild,v 1.1 2004/05/07 19:30:39 agriffis Exp $
+
+IUSE=""
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/${P}.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 mips"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -type l -maxdepth 1 | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}