summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-app-form/zope-app-form-3.9.0.ebuild')
-rw-r--r--net-zope/zope-app-form/zope-app-form-3.9.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-zope/zope-app-form/zope-app-form-3.9.0.ebuild b/net-zope/zope-app-form/zope-app-form-3.9.0.ebuild
new file mode 100644
index 000000000000..d4cc3558a272
--- /dev/null
+++ b/net-zope/zope-app-form/zope-app-form-3.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-form/zope-app-form-3.9.0.ebuild,v 1.1 2009/11/14 16:13:35 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Original Zope 3 Form Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.app.form"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/transaction
+ net-zope/zope-app-basicskin
+ net-zope/zope-app-pagetemplate
+ net-zope/zope-browser
+ net-zope/zope-browsermenu
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-datetime
+ net-zope/zope-event
+ net-zope/zope-exceptions
+ net-zope/zope-i18n
+ net-zope/zope-interface
+ net-zope/zope-lifecycleevent
+ net-zope/zope-proxy
+ net-zope/zope-publisher
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN//-//}"
+DOCS="CHANGES.txt README.txt"