summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-traversing/zope-traversing-3.10.0.ebuild')
-rw-r--r--net-zope/zope-traversing/zope-traversing-3.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-zope/zope-traversing/zope-traversing-3.10.0.ebuild b/net-zope/zope-traversing/zope-traversing-3.10.0.ebuild
new file mode 100644
index 000000000000..52835d36c2ca
--- /dev/null
+++ b/net-zope/zope-traversing/zope-traversing-3.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-traversing/zope-traversing-3.10.0.ebuild,v 1.1 2009/12/20 01:37:23 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Resolving paths in the object hierarchy"
+HOMEPAGE="http://pypi.python.org/pypi/zope.traversing"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-component
+ net-zope/zope-i18n
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-publisher
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"