summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/elph/elph-0.1.5.ebuild')
-rw-r--r--sci-biology/elph/elph-0.1.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/elph/elph-0.1.5.ebuild b/sci-biology/elph/elph-0.1.5.ebuild
new file mode 100644
index 000000000000..ea8c56129428
--- /dev/null
+++ b/sci-biology/elph/elph-0.1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/elph/elph-0.1.5.ebuild,v 1.1 2005/01/28 00:47:21 ribosome Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Estimated Locations of Pattern Hits - Motif finder program"
+HOMEPAGE="http://www.tigr.org/software/ELPH/index.shtml"
+SRC_URI="ftp://ftp.tigr.org/pub/software/ELPH/ELPH-${PV}.tar.gz"
+LICENSE="Artistic"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/ELPH/sources"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-usage.patch
+ sed -i -e "s/CC := g++/CC := $(tc-getCXX)/" Makefile
+ sed -i -e "s/-fno-exceptions -fno-rtti -D_REENTRANT -g/${CXXFLAGS}/" Makefile
+ sed -i -e "s/LINKER := g++/LINKER := $(tc-getCXX)/" Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dobin elph
+ cd ${WORKDIR}/ELPH
+ dodoc VERSION
+ newdoc Readme.ELPH README
+}