summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild')
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
index ef62dfef8893..c4135bd46b8c 100644
--- a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
+++ b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild,v 1.3 2009/12/25 17:56:38 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild,v 1.4 2012/08/04 21:52:55 bicatali Exp $
-EAPI=1
+EAPI=4
inherit eutils cmake-utils
DESCRIPTION="A fast and usable calculator for power users"
-HOMEPAGE="http://speedcrunch.org/"
+HOMEPAGE="https://code.google.com/p/speedcrunch/"
SRC_URI="http://speedcrunch.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc"
DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
LANGS="ca cs de en es es_AR eu fi fr he id it nb nl no pl
pt pt_BR ro ru sv tr zh_CN"
@@ -25,12 +26,11 @@ done
S="${WORKDIR}/${P}/src"
-src_unpack( ) {
- unpack ${A}
- cd "${S}"
+src_prepare( ) {
epatch "${FILESDIR}"/${P}-iconname.patch
# regenerate translations
lrelease speedcrunch.pro || die
+ local lang
for lang in ${LANGS}; do
if ! use linguas_${lang}; then
sed -i -e "s:i18n/${lang}\.qm::" Translations.cmake || die
@@ -43,8 +43,5 @@ src_install() {
cmake-utils_src_install
cd ..
dodoc ChangeLog ChangeLog.floatnum HACKING.txt LISEZMOI README TRANSLATORS
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die
- fi
+ use doc && dodoc doc/*.pdf
}