summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/ChangeLog10
-rw-r--r--sci-chemistry/pdbmat/Manifest5
-rw-r--r--sci-chemistry/pdbmat/files/CMakeLists.txt14
-rw-r--r--sci-chemistry/pdbmat/metadata.xml34
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89.ebuild29
5 files changed, 92 insertions, 0 deletions
diff --git a/sci-chemistry/pdbmat/ChangeLog b/sci-chemistry/pdbmat/ChangeLog
new file mode 100644
index 000000000000..25dccd8a23e2
--- /dev/null
+++ b/sci-chemistry/pdbmat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/pdbmat
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdbmat/ChangeLog,v 1.1 2012/03/21 13:47:43 jlec Exp $
+
+*pdbmat-3.89 (21 Mar 2012)
+
+ 21 Mar 2012; Justin Lecher <jlec@gentoo.org> +pdbmat-3.89.ebuild,
+ +files/CMakeLists.txt, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-chemistry/pdbmat/Manifest b/sci-chemistry/pdbmat/Manifest
new file mode 100644
index 000000000000..612f4d9d02c9
--- /dev/null
+++ b/sci-chemistry/pdbmat/Manifest
@@ -0,0 +1,5 @@
+AUX CMakeLists.txt 414 RMD160 797f3a4ceae9a60fe54d0a7065316d8dec32ee94 SHA1 a522bec6210a4904fd98521561576c61a421f922 SHA256 3892dbed23bf2283ce369dc5a2d89c0eded875d615704532fb038ccbe2c90436
+DIST pdbmat-3.89.tar.gz 124727 RMD160 8fa61884a89c8c615d1251ff9c337eaf81a70531 SHA1 e8784d36bd9f74b8605c6d9ec950195253850338 SHA256 98f75acd3da3f172213de0688825abad8b3a59c516b5b4ac411a494f6d355f72
+EBUILD pdbmat-3.89.ebuild 635 RMD160 5e8dbb20089917418635880846fef6b57b24272d SHA1 9b36c3b575bb465dfd63830c16a06e3041594669 SHA256 0da19e5d89956ccd481af441fd2136dc33b63acb0d59d7dcc2768090a4a23a45
+MISC ChangeLog 288 RMD160 884ff10b274efae8bb13befab654b0bec05fec35 SHA1 6da06b2f1eede70cb7f82c5adf162ad01764f29a SHA256 24ab8857fcb6d6d064e721c410a80f810170e912bd92d1c6171225eb6358ff07
+MISC metadata.xml 1256 RMD160 3e45e1853f37c640f26cc1ba0dccde856669ff35 SHA1 d3f81866f981705e28e9aab3f563616e67d926b1 SHA256 9cfd94af34405cdde86a1c22ec44db92b9d3c609e061d98ea8178268a04ea1f2
diff --git a/sci-chemistry/pdbmat/files/CMakeLists.txt b/sci-chemistry/pdbmat/files/CMakeLists.txt
new file mode 100644
index 000000000000..2f1937d84b3f
--- /dev/null
+++ b/sci-chemistry/pdbmat/files/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 2.6)
+project (PDBMAT Fortran)
+
+option (EXAMPLES "Instal additional example files" OFF)
+
+add_executable(diagstd diagstd.f)
+add_executable(pdbmat pdbmat.f)
+
+install (TARGETS diagstd pdbmat DESTINATION bin)
+install (FILES diagstd.README pdbmat.README DESTINATION share/doc/pdbmat)
+
+if ( EXAMPLES )
+ install (DIRECTORY ../Try_ENM2011 DESTINATION share/pdbmat/examples)
+endif (EXAMPLES)
diff --git a/sci-chemistry/pdbmat/metadata.xml b/sci-chemistry/pdbmat/metadata.xml
new file mode 100644
index 000000000000..110c57fb33b9
--- /dev/null
+++ b/sci-chemistry/pdbmat/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+$Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdbmat/metadata.xml,v 1.1 2012/03/21 13:47:43 jlec Exp $
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed: herd, maintainer, and
+longdescription. herd is a required subelement.
+
+For a full description look at:
+http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=4
+
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+ <!-- <herd>some-herd</herd> -->
+ <maintainer>
+ <email>@gentoo.org</email>
+ <!-- <description>Description of the maintainership</description> -->
+ </maintainer>
+ <!-- <longdescription>Long description of the package</longdescription> -->
+ <!--
+<use>
+ <flag name='flag'>Description of how USE='flag' affects this package</flag>
+ <flag name='userland_GNU'>Description of how USERLAND='GNU' affects this
+ package</flag>
+ <flag name='aspell'>Uses <pkg>app-text/aspell</pkg> for spell checking.
+ Requires an installed dictionary from <cat>app-dicts</cat></flag>
+</use>
+-->
+</pkgmetadata>
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
new file mode 100644
index 000000000000..598ca05c37c7
--- /dev/null
+++ b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdbmat/pdbmat-3.89.ebuild,v 1.1 2012/03/21 13:47:43 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculate Tirion's model from pdb structures"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+S="${WORKDIR}"/Source_ENM2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use examples EXAMPLES)
+ )
+ cmake-utils_src_configure
+}