summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/oregano')
-rw-r--r--sci-electronics/oregano/ChangeLog6
-rw-r--r--sci-electronics/oregano/files/oregano-0.69.1-fix-libm.patch11
-rw-r--r--sci-electronics/oregano/oregano-0.69.1-r1.ebuild5
-rw-r--r--sci-electronics/oregano/oregano-0.69.1.ebuild53
4 files changed, 19 insertions, 56 deletions
diff --git a/sci-electronics/oregano/ChangeLog b/sci-electronics/oregano/ChangeLog
index c1180db64e36..98f503ce3a26 100644
--- a/sci-electronics/oregano/ChangeLog
+++ b/sci-electronics/oregano/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/oregano
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/ChangeLog,v 1.58 2014/08/10 20:28:33 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/ChangeLog,v 1.59 2014/11/12 21:46:23 dlan Exp $
+
+ 12 Nov 2014; Yixun Lan <dlan@gentoo.org> -oregano-0.69.1.ebuild,
+ oregano-0.69.1-r1.ebuild, +files/oregano-0.69.1-fix-libm.patch:
+ drop old; fix unresolved symbol, missing -lm, bug 527828, thanks Fat-Zer
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> oregano-0.69.1-r1.ebuild,
oregano-0.69.1.ebuild, oregano-0.82.ebuild:
diff --git a/sci-electronics/oregano/files/oregano-0.69.1-fix-libm.patch b/sci-electronics/oregano/files/oregano-0.69.1-fix-libm.patch
new file mode 100644
index 000000000000..420ffe17f00c
--- /dev/null
+++ b/sci-electronics/oregano/files/oregano-0.69.1-fix-libm.patch
@@ -0,0 +1,11 @@
+--- src/SConscript.old 2009-07-07 19:49:49.000000000 +0400
++++ src/SConscript 2014-11-12 20:57:50.311089881 +0300
+@@ -67,6 +67,8 @@
+
+ SrcEnv.Append (CCFLAGS = Split ("-I./src -I./src/model -I./src/sheet -I./src/gplot -I./data/dialogs -I./src/engines"))
+
++SrcEnv.Append (LIBS = ['m'])
++
+ oregano = SrcEnv.Program ('oregano', files)
+
+ # Install alias # \ No newline at end of file
diff --git a/sci-electronics/oregano/oregano-0.69.1-r1.ebuild b/sci-electronics/oregano/oregano-0.69.1-r1.ebuild
index 356bc77f79e4..5506d29f0117 100644
--- a/sci-electronics/oregano/oregano-0.69.1-r1.ebuild
+++ b/sci-electronics/oregano/oregano-0.69.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/oregano-0.69.1-r1.ebuild,v 1.8 2014/08/10 20:28:33 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/oregano-0.69.1-r1.ebuild,v 1.9 2014/11/12 21:46:23 dlan Exp $
-EAPI="4"
+EAPI="5"
inherit eutils fdo-mime flag-o-matic scons-utils
@@ -33,6 +33,7 @@ src_prepare() {
# patches from debian
epatch "${FILESDIR}/${P}-desktop_file_update.patch"
epatch "${FILESDIR}/${P}-scons_env_flags.patch"
+ epatch "${FILESDIR}/${P}-fix-libm.patch"
}
src_compile() {
diff --git a/sci-electronics/oregano/oregano-0.69.1.ebuild b/sci-electronics/oregano/oregano-0.69.1.ebuild
deleted file mode 100644
index dc8cdd548cac..000000000000
--- a/sci-electronics/oregano/oregano-0.69.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/oregano/oregano-0.69.1.ebuild,v 1.9 2014/08/10 20:28:33 slyfox Exp $
-
-EAPI="4"
-
-inherit eutils fdo-mime scons-utils
-
-DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
-HOMEPAGE="http://oregano.gforge.lug.fi.uba.ar/" # broken
-SLOT="0"
-KEYWORDS="~amd64 ppc ~x86"
-LICENSE="GPL-2"
-IUSE=""
-
-CDEPEND="
- dev-libs/libxml2:2
- x11-libs/gtk+:2
- gnome-base/libglade:2.0
- gnome-base/libgnome
- >=gnome-base/libgnomeui-2.12
- >=gnome-base/libgnomecanvas-2.12
- >=x11-libs/cairo-1.2
- x11-libs/gtksourceview:2.0"
-DEPEND="${CDEPEND}
- >=dev-util/scons-0.96.1
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sci-electronics/electronics-menu"
-
-src_prepare() {
- # patches from debian
- epatch "${FILESDIR}/${P}-desktop_file_update.patch"
- epatch "${FILESDIR}/${P}-scons_env_flags.patch"
-}
-
-src_compile() {
- escons --cache-disable PREFIX=/usr
-}
-
-src_install() {
- escons --cache-disable PREFIX=/usr DESTDIR="${D}" RunUpdateMimeDatabase=no \
- install
- dodoc AUTHORS NEWS README
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- elog "You'll need to emerge your prefered simulation backend"
- elog "such as spice, ngspice or gnucap for simulation"
- elog "to work."
-}