summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/armadillo/armadillo-3.4.4.ebuild')
-rw-r--r--sci-libs/armadillo/armadillo-3.4.4.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/sci-libs/armadillo/armadillo-3.4.4.ebuild b/sci-libs/armadillo/armadillo-3.4.4.ebuild
index 7d0d6d879738..53b65df7879c 100644
--- a/sci-libs/armadillo/armadillo-3.4.4.ebuild
+++ b/sci-libs/armadillo/armadillo-3.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.1 2012/11/20 00:06:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.2 2012/12/12 18:23:10 bicatali Exp $
EAPI=4
@@ -15,11 +15,10 @@ SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="atlas blas doc examples lapack"
+IUSE="blas doc examples lapack"
RDEPEND="
dev-libs/boost
- atlas? ( sci-libs/lapack-atlas )
blas? ( virtual/blas )
lapack? ( virtual/lapack )"
@@ -45,16 +44,6 @@ src_configure() {
-DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
)
fi
- if use atlas; then
- mycmakeargs=(
- -DARMA_USE_ATLAS=ON
- -DCBLAS_FOUND=ON
- -DCLAPACK_FOUND=ON
- -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
- -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
- -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
- )
- fi
cmake-utils_src_configure
}