summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gerris/gerris-20100519.ebuild')
-rw-r--r--sci-libs/gerris/gerris-20100519.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/gerris/gerris-20100519.ebuild b/sci-libs/gerris/gerris-20100519.ebuild
new file mode 100644
index 000000000000..c8d8001bc29f
--- /dev/null
+++ b/sci-libs/gerris/gerris-20100519.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20100519.ebuild,v 1.1 2010/05/21 14:00:06 jlec Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="The Gerris Flow Solver"
+LICENSE="GPL-2"
+HOMEPAGE="http://gfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gfs/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples mpi"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ sci-libs/netcdf
+ sci-libs/gsl
+ sci-libs/gts
+ sci-libs/proj
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# test assume it is installed
+RESTRICT="test"
+
+S="${WORKDIR}"/${PN}-snapshot-100519
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable mpi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake nstall failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ rm -f doc/examples/*.pyc || die "Failed to remove python object"
+ doins -r doc/examples/* || die
+ fi
+}