summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeda/ChangeLog7
-rw-r--r--sci-libs/libgeda/libgeda-1.1.1.ebuild54
-rw-r--r--sci-libs/libgeda/libgeda-1.2.0.ebuild54
-rw-r--r--sci-libs/libgeda/libgeda-20060123.ebuild41
-rw-r--r--sci-libs/libgeda/libgeda-20061020.ebuild53
-rw-r--r--sci-libs/libgeda/libgeda-20070216.ebuild53
-rw-r--r--sci-libs/libgeda/libgeda-20070526.ebuild53
7 files changed, 6 insertions, 309 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index 492eecc8851e..a3602121e942 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libgeda
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.44 2008/03/22 09:55:03 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.45 2008/03/22 19:05:16 calchan Exp $
+
+ 22 Mar 2008; Denis Dupeyron <calchan@gentoo.org> -libgeda-1.1.1.ebuild,
+ -libgeda-1.2.0.ebuild, -libgeda-20060123.ebuild, -libgeda-20061020.ebuild,
+ -libgeda-20070216.ebuild, -libgeda-20070526.ebuild:
+ Post stabilization cleanup.
22 Mar 2008; nixnut <nixnut@gentoo.org> libgeda-1.4.0.ebuild:
Stable on ppc wrt bug 192905
diff --git a/sci-libs/libgeda/libgeda-1.1.1.ebuild b/sci-libs/libgeda/libgeda-1.1.1.ebuild
deleted file mode 100644
index 5947cf9a4315..000000000000
--- a/sci-libs/libgeda/libgeda-1.1.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.1.1.ebuild,v 1.2 2007/09/19 11:44:03 calchan Exp $
-
-inherit eutils
-
-SUBDIR="v1.1"
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/devel/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- =dev-scheme/guile-1.8*
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- ${S}/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
diff --git a/sci-libs/libgeda/libgeda-1.2.0.ebuild b/sci-libs/libgeda/libgeda-1.2.0.ebuild
deleted file mode 100644
index 13fec1231c7e..000000000000
--- a/sci-libs/libgeda/libgeda-1.2.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.2.0.ebuild,v 1.1 2007/09/18 09:56:27 calchan Exp $
-
-inherit eutils
-
-SUBDIR="v1.2"
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- ${S}/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
diff --git a/sci-libs/libgeda/libgeda-20060123.ebuild b/sci-libs/libgeda/libgeda-20060123.ebuild
deleted file mode 100644
index c63b511e1264..000000000000
--- a/sci-libs/libgeda/libgeda-20060123.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20060123.ebuild,v 1.10 2007/03/09 20:07:20 calchan Exp $
-
-inherit eutils
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="png"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc sparc x86"
-SLOT="0"
-
-DEPEND=">=dev-libs/glib-2.4.8
- >=x11-libs/gtk+-2.2
- >=dev-scheme/guile-1.6.3
- >=dev-util/pkgconfig-0.15.0
- png? ( >=sci-libs/libgdgeda-2.0.15 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
-}
-
-src_compile () {
- local myconf
-
- use png || myconf='--disable-gdgeda'
-
- econf ${myconf} || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install () {
- einstall || die "Installation failed"
- dodoc AUTHORS COPYING ChangeLog README
-}
diff --git a/sci-libs/libgeda/libgeda-20061020.ebuild b/sci-libs/libgeda/libgeda-20061020.ebuild
deleted file mode 100644
index 3144a16263cd..000000000000
--- a/sci-libs/libgeda/libgeda-20061020.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20061020.ebuild,v 1.7 2007/03/09 20:07:20 calchan Exp $
-
-inherit eutils
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE=""
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- ${S}/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- econf \
- --disable-gdgeda \
- --disable-dependency-tracking \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- einstall || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
diff --git a/sci-libs/libgeda/libgeda-20070216.ebuild b/sci-libs/libgeda/libgeda-20070216.ebuild
deleted file mode 100644
index e5691a0826b5..000000000000
--- a/sci-libs/libgeda/libgeda-20070216.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20070216.ebuild,v 1.3 2007/04/07 20:16:35 calchan Exp $
-
-inherit eutils
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- ${S}/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
diff --git a/sci-libs/libgeda/libgeda-20070526.ebuild b/sci-libs/libgeda/libgeda-20070526.ebuild
deleted file mode 100644
index eae3535cf66c..000000000000
--- a/sci-libs/libgeda/libgeda-20070526.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20070526.ebuild,v 1.1 2007/06/02 16:16:12 calchan Exp $
-
-inherit eutils
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- ${S}/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}