summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/Manifest12
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11-r11
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.4.11-r1.ebuild39
4 files changed, 49 insertions, 11 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index b7b2b00e0b9f..3bfe68f91d02 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.8 2005/09/23 00:43:20 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.9 2005/10/02 03:13:43 ribosome Exp $
+
+*mathomatic-12.4.11-r1 (02 Oct 2005)
+
+ 02 Oct 2005; Olivier Fisette <ribosome@gentoo.org>
+ +mathomatic-12.4.11-r1.ebuild:
+ Fixed readline support (bug #107109).
*mathomatic-12.4.11 (23 Sep 2005)
diff --git a/sci-mathematics/mathomatic/Manifest b/sci-mathematics/mathomatic/Manifest
index 2641498f9d93..ae613dc956d2 100644
--- a/sci-mathematics/mathomatic/Manifest
+++ b/sci-mathematics/mathomatic/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 cab3b12f4c7dee5812f750b010150533 mathomatic-12.4.11-r1.ebuild 962
MD5 f38bccf593e0f1fb97f5b13047bdd99e mathomatic-12.4.5.ebuild 942
MD5 3bcddd67111a9ae99e5f5e2bd8533332 mathomatic-12.4.11.ebuild 940
MD5 17680c528466a8822429ef8bb61fdde3 ChangeLog 2184
MD5 ee7955cc2715e3bac994bb045163c8b1 metadata.xml 479
MD5 32a964754f69321292b8d2b29b2d89c0 files/digest-mathomatic-12.4.5 66
+MD5 bf6afb923996c68d8e305c5a2124a6e5 files/digest-mathomatic-12.4.11-r1 67
MD5 bf6afb923996c68d8e305c5a2124a6e5 files/digest-mathomatic-12.4.11 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDM0+1ntT9W3vfTuoRAoPMAJ0biHSWkrIdZcst8wsM8YrxTE5w9wCfZIEw
-h6eBowo2r4GfXjJ9nvqh5vw=
-=GTZh
------END PGP SIGNATURE-----
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11-r1 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11-r1
new file mode 100644
index 000000000000..8ca71befb3f3
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11-r1
@@ -0,0 +1 @@
+MD5 ee54e976e1a99f8e08fa6c4a4e7924ad mathomatic-12.4.11.tgz 128156
diff --git a/sci-mathematics/mathomatic/mathomatic-12.4.11-r1.ebuild b/sci-mathematics/mathomatic/mathomatic-12.4.11-r1.ebuild
new file mode 100644
index 000000000000..cc341113d20e
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.4.11-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.4.11-r1.ebuild,v 1.1 2005/10/02 03:13:43 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake READLINE=1 || die "emake failed"
+ else
+ emake READLINE=1 || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman doc/mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}