summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/scilab/scilab-4.1.1.ebuild')
-rw-r--r--sci-mathematics/scilab/scilab-4.1.1.ebuild28
1 files changed, 8 insertions, 20 deletions
diff --git a/sci-mathematics/scilab/scilab-4.1.1.ebuild b/sci-mathematics/scilab/scilab-4.1.1.ebuild
index 9992ad4e8585..0f0e678f1a15 100644
--- a/sci-mathematics/scilab/scilab-4.1.1.ebuild
+++ b/sci-mathematics/scilab/scilab-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.1.ebuild,v 1.2 2007/05/23 01:37:54 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.1.ebuild,v 1.3 2007/05/30 12:52:45 markusle Exp $
inherit eutils fortran toolchain-funcs multilib autotools java-pkg-opt-2
@@ -10,7 +10,7 @@ SRC_URI="http://www.scilab.org/download/${PV}/${P}-src.tar.gz"
HOMEPAGE="http://www.scilab.org/"
SLOT="0"
-IUSE="ocaml tk gtk Xaw3d java"
+IUSE="ocaml gtk Xaw3d java"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="virtual/blas
@@ -24,8 +24,8 @@ RDEPEND="virtual/blas
x11-libs/vte
=gnome-extra/gtkhtml-2*
)
- tk? ( >=dev-lang/tk-8.4
- >=dev-lang/tcl-8.4 )
+ >=dev-lang/tk-8.4
+ >=dev-lang/tcl-8.4
Xaw3d? ( x11-libs/Xaw3d )
ocaml? ( dev-lang/ocaml )
java? ( >=virtual/jdk-1.4 )"
@@ -34,20 +34,6 @@ DEPEND="${RDEPEND}
app-text/sablotron"
pkg_setup() {
- if ! use gtk && ! use tk; then
- echo
- eerror 'scilab must be built with either USE="gtk" or USE="tk"'
- die
- fi
-
- if use gtk && use tk; then
- echo
- ewarn "You have selected both gtk and tk support which"
- ewarn "are mutually exclusive. In this case, the gtk "
- ewarn "interface will be built."
- epause 5
- fi
-
java-pkg-opt-2_pkg_setup
need_fortran gfortran g77
}
@@ -94,12 +80,14 @@ src_compile() {
local myopts
myopts="${myopts} --with-atlas-library=/usr/$(get_libdir)"
+ # the tk interface is the default
+ myopts="${myopts} --with-tk"
+
if [[ ${FORTRANC} == gfortran ]]; then
myopts="${myopts} --with-gfortran"
fi
- econf $(use_with tk) \
- $(use_with Xaw3d xaw3d) \
+ econf $(use_with Xaw3d xaw3d) \
$(use_with gtk gtk2 ) \
$(use_with ocaml) \
$(use_with java ) \