summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/scigraphica/files/scigraphica-2.1.0-arrayobject.patch')
-rw-r--r--sci-visualization/scigraphica/files/scigraphica-2.1.0-arrayobject.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-visualization/scigraphica/files/scigraphica-2.1.0-arrayobject.patch b/sci-visualization/scigraphica/files/scigraphica-2.1.0-arrayobject.patch
new file mode 100644
index 000000000000..faf851624d0d
--- /dev/null
+++ b/sci-visualization/scigraphica/files/scigraphica-2.1.0-arrayobject.patch
@@ -0,0 +1,15 @@
+diff -urN scigraphica-2.1.0/configure.in scigraphica-2.1.0.new/configure.in
+--- scigraphica-2.1.0/configure.in 2005-06-24 02:43:36.000000000 +0100
++++ scigraphica-2.1.0.new/configure.in 2006-06-08 17:06:44.000000000 +0100
+@@ -381,9 +381,9 @@
+ PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
+ PY_LIBS="python$PY_VERSION"
+ PY_LIB_LOC="$PY_EXEC_PREFIX/lib/python$PY_VERSION/"
+- array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ if test x$array_loc = x; then
+- array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ fi
+ if test -n $array_loc -a -d $array_loc; then
+ echo "$array_loc"