summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild')
-rw-r--r--sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild35
1 files changed, 26 insertions, 9 deletions
diff --git a/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
index 40a728d83fb3..87ce20847643 100644
--- a/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
+++ b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild,v 1.4 2004/06/24 21:59:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild,v 1.5 2004/07/23 22:26:09 solar Exp $
IUSE="build bootstrap uclibc"
@@ -11,25 +11,32 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-*"
+#PROVIDE="virtual/baselayout"
+#DEPEND="!virtual/baselayout"
+
S="${WORKDIR}/${PN}"
src_install() {
- keepdir /bin /etc /etc/init.d /home /lib /sbin /usr /var /proc /root /mnt
+ keepdir /bin /etc /etc/init.d /home /lib /sbin /usr /var /root /mnt
+
+ # (Jul 23 2004 -solar)
+ # This fails a when merging if /proc is already mounted. We
+ # could postinst it but 99% of the time we only are building
+ # this port as a package via emerge -B
+ #keepdir /proc
insinto /etc
doins ${S}/{fstab,group,nsswitch.conf,passwd,profile.env,protocols,shells}
doins ${S}/init/inittab
+
use uclibc && rm -f ${D}/etc/nsswitch.conf
exeinto /etc/init.d
doexe ${S}/init/rc[SK]
-}
-pkg_postinst() {
- # Doing device node creation here, since portage doesnt record
- # device nodes in CONTENTS
+ mkdir -p ${D}/dev
- cd ${ROOT}/dev
+ cd ${D}/dev || die
einfo "Making device nodes (this could take a minute or so...)"
MAKEDEV std
@@ -37,13 +44,16 @@ pkg_postinst() {
for i in 0 1 2 3 4; do
mknod -m 0660 hda${i/0} b 3 ${i}
- chown root:disk hda${i/0}
+ mknod -m 0660 sda${i/0} b 8 ${i}
+ chown root:disk hda${i/0} sda${i/0}
mknod -m 0600 tty${i} c 4 ${i}
chown root:tty tty${i}
done
MAKEDEV ttyS0
+}
+pkg_postinst() {
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a build.
@@ -52,5 +62,12 @@ pkg_postinst() {
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
fi
-}
+ # Doing device node creation here, since portage doesnt record
+ # device nodes in CONTENTS
+
+ # (Jul 23 2004 -solar)
+ # Moved device node creation to src_install() so that we can get
+ # the device nods into a binary package which can then be
+ # installed on a host which does not have python/portage etc.
+}