summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpudyn/cpudyn-0.6.1.ebuild')
-rw-r--r--sys-apps/cpudyn/cpudyn-0.6.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/cpudyn/cpudyn-0.6.1.ebuild b/sys-apps/cpudyn/cpudyn-0.6.1.ebuild
new file mode 100644
index 000000000000..6219828052e2
--- /dev/null
+++ b/sys-apps/cpudyn/cpudyn-0.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpudyn/cpudyn-0.6.1.ebuild,v 1.1 2004/01/20 00:34:36 robbat2 Exp $
+
+DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
+HOMEPAGE="http://mnm.uib.es/~gallir/${PN}/"
+SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir gentoo
+ cp debian/cpudyn.conf gentoo
+ cp ${FILESDIR}/cpudyn.init gentoo
+ epatch ${FILESDIR}/${PN}-0.5.0-init_conf_updates.patch
+}
+
+src_compile() {
+ emake cpudynd || die "Compilation failed."
+}
+
+src_install() {
+ into /
+ exeinto /etc/init.d
+ newexe gentoo/cpudyn.init cpudyn
+ insinto /etc/conf.d
+ newins gentoo/cpudyn.conf cpudyn
+
+ into /usr
+ doman cpudynd.8
+ dosbin cpudynd
+ dodoc INSTALL README VERSION changelog COPYING
+ dohtml *.html
+}
+
+pkg_postinst() {
+ einfo "Configuration file is /etc/conf.d/cpudyn."
+}