summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gradm/gradm-1.9.11.ebuild')
-rw-r--r--sys-apps/gradm/gradm-1.9.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/gradm/gradm-1.9.11.ebuild b/sys-apps/gradm/gradm-1.9.11.ebuild
new file mode 100644
index 000000000000..4361a2f85a1f
--- /dev/null
+++ b/sys-apps/gradm/gradm-1.9.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-1.9.11.ebuild,v 1.1 2003/06/24 13:41:58 solar Exp $
+
+DESCRIPTION="Administrative interface for grsecurity ${PV} access control lists"
+SRC_URI="http://www.grsecurity.net/${P}.tar.gz"
+HOMEPAGE="http://www.grsecurity.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64 ~sparc ~ppc"
+SLOT="0"
+
+IUSE=""
+DEPEND="virtual/glibc
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/chpax"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gradm_parse.c-1.9.x.patch
+ mv Makefile{,.orig}
+ sed -e "s|-O2|${CFLAGS}|" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake CC="${CC}" || die "compile problem"
+}
+
+src_install() {
+ doman gradm.8
+ dodoc acl
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/grsecurity.rc grsecurity
+ insinto /etc/conf.d
+ doins ${FILESDIR}/grsecurity
+ into /
+ dosbin gradm
+ fperms 700 /sbin/gradm
+}